Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0.7.0

Hier kommen die Support Anfragen für phpBB 3.0.x MODs hinein.
Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0.7.0

Beitragvon techno-com » 25. Feb 2012 08:28

Deine phpBB Version: 3.0.10
Typ Deines phpBB Forums: Standard phpBB (auch Vanilla (phpbb2) oder Olympus (phpBB3) genannt)
MODs installiert: Ja
Dein Wissensstand: Grundwissen
Link zu Deinem Forum: http://www.techno-com.de/Forum

PHP Version: PHP Version 5.3.10-nmm1
MySQL Version: MySQL 5.1.43-nmm4-log

Was hast Du gemacht, bevor das Problem aufgetreten ist?
diese Mods alle erst mit Mahony Unterstützung installiert

Was hast Du bereits versucht um das Problem zu lösen?
"Best-English" Versuche unternommen von http://www.phpbb.com/customise/db/mod/t ... bab9562e40 , aber wenig verstanden von den vielen Replace-Anweisungen und noch nicht einmal bewusst ob das überhaupt mein Problem ist

Fehlerbeschreibung und Nachricht
Hi Mahony.... me again ! Dich kann man ja hier schon direkt ansprechen (in dieser Rubrik wenigstens), ist ja wie bei mir im Forum :mrgreen: ;)

Es "funktioniert" bei mir akt. alles super gut, ich war noch nie so zufrieden mit dem Forum wie aktuell. Keine Meldungen von Usern das etwas nicht klappt und nach deinen ganzen Unterstützungen weiß ich jetzt sogar fast genau wie die Zugangsberechtigungen einzustellen sind für meine Wünsche.. aber div. Fragen/Probleme habe ich noch und frag jetzt mal an:

1. Berechtigungen
Wie sinnvoll hältst z.B. du es das Forum für unangemeldete User fürs "lesen" auch zu sperren ? Wenn ich das richtig verstanden habe kann ich ja den BOTS eine Leseberechtigung erteilen und die über dann z.B. Google suchenden User finden auch den Text im Forum.... wenn sie aber dann rüber kommen müssten sie sich zuerst anmelden um alles lesen zu können bzw. um Sachen anschauen zu können / runter laden zu können !
Das natürlich nur in den "Beratungsrubriken" und nicht in den "News-Rubriken".
Dafür müsste ich einfach den "unangemeldeten Usern" die Leseberechtigung entziehen, richtig ? Noch auf etwas zu achten ?
Sinn davon soll es sein die User zu "binden" (obwohl ich übers Forum und auch über meinen Shop eigentlich noch NIE einen Newsletter versendet habe).

2. SEO-URL Problem
Klick mal auf der Startseite auf einen Beitrag (dem ist NICHT so in einer Rubrik - dort geht es !) .... der wird dann z.B. angezeigt als http://www.techno-com.de/Forum/topic7398.html und erst wenn ich dann IN dem Beitrag noch einmal auf den Beitragstitel klicke kommt die umgewandelte SEO-URL http://www.techno-com.de/Forum/kopfstat ... tml#p14261
2.1. Sollte natürlich IMMER gleich die SEO-URL kommen
2.2. lese ich immer von Zero-Dupe ... meiner Meinung nach habe ich das mal installiert :rotwerd - finde aber im ACP absolut nichts davon ! Habe dann das hier gefunden: http://www.phpbb.com/customise/db/mod/t ... bab9562e40 , aber die vielen verschiedenen Beiträge mit einer Änderung nach der anderen bringt mich da nicht viel weiter was GENAU alles zu mache ist und warum eigentlich ! Ich möchte ja nicht total ahnungslos "mal wieder" ins Coding eingreifen und dabei dann ggf. wieder das Forum lahm legen wegen neuer .htaccess Probleme.

3. Thanks-MOD
Da zerreisst es mir akt. die Struktur/den Aufbau eines Beitrags !
Schau mal unter http://www.techno-com.de/Forum/anderung ... t7285.html ! Der erste Beitrag hat ein "Danke" erhalten. Das Danke wird unter dem Beitrag angezeigt, aber die Userdaten werden mit in diese ZEILE runter gezogen und werden nicht oben beim Beitrag stehen gelassen ..... wenn dann die Userangaben (Bild, etc.) enthalten wird das ziemlich lange und verzerrt den ganzen Beitragsaufbau... ich hoffe du verstehst hier was ich meine !

4. Social-PlugIns

Habe bei div. Durcharbeitungen meiner Seitenbewertung gesehen das Social-Networks immer mehr auf die Google-Bewertung durchschlagen und vor allem auf die Akzeptanz bei Usern nützlich sind, vor allem auch für die "Eigenwerbung" (den Like-Button kann man ja selbst drücken :lol: und somit Links schaffen fürs "gefunden werden").
Es gibt einfache Anleitungen wie man einen Facebook-Button, Twitter-Link und/oder auch GooglePlus1-Button anbringt. Mir wäre das aber viel lieber in einer "all in One Lösung" (und da finde ich AddThis nicht gut).... was für Möglichkeiten des "Einbindens" findest du gut und was schlägst du für Lösungen über das ACP vor ? Das wäre mein Favorite....
Auf meiner Startseite war es mir z.B. akt. selbst unmöglich das alles zu integrieren, außer ganz unten über AddThis (gefundene Anleitung dort aus dem Netz).

-------
Nachtrag der mir gerade beim selbst durchspielen der diversen Szenarien für das zusammentragen der Links hier aufgefallen ist:
Wenn ich z.B. in meinen Userangaben auf "Danke erhalten" klicke wird auf den Beitrag verlinkt der dieses Danke erhalten hat. Auch dort wenn ich auf den Betreff klicke wird wieder verlinkt auf z.B. http://www.techno-com.de/Forum/post14149.html#p14149 , also auch nicht "SEO-Rewrite-mässig" !
Zuletzt geändert von techno-com am 25. Feb 2012 12:10, insgesamt 3-mal geändert.
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 744
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0

Beitragvon Mahony » 25. Feb 2012 08:55

Hallo
Zu 1.
techno-com hat geschrieben:Dafür müsste ich einfach den "unangemeldeten Usern" die Leseberechtigung entziehen, richtig ?

Ja, du musst dann der Gruppe Gäste die entsprechenden Berechtigungen entziehen. siehe dazu auch Rechtevergabe im phpBB3

Zu 2.
techno-com hat geschrieben:Klick mal auf der Startseite auf einen Beitrag (dem ist NICHT so in einer Rubrik - dort geht es !) .... der wird dann z.B. angezeigt als http://www.techno-com.de/Forum/topic7398.html und erst wenn ich dann IN dem Beitrag noch einmal auf den Beitragstitel klicke kommt die umgewandelte SEO-URL http://www.techno-com.de/Forum/kopfstat ... tml#p14261
2.1. Sollte natürlich IMMER gleich die SEO-URL kommen

Wie schon einmal gesagt, kann ich dir dabei nicht behilflich sein da ich nicht so der mod_rewrite Experte bin.

Zu3.
techno-com hat geschrieben:Da zerreisst es mir akt. die Struktur/den Aufbau eines Beitrags !

Ich kann mir das nächste Woche mal ansehen. Im Moment habe ich nicht die nötige Zeit dazu.

techno-com hat geschrieben:Nachtrag der mir gerade beim selbst durchspielen der diversen Szenarien für das zusammentragen der Links hier aufgefallen ist:
Wenn ich z.B. in meinen Userangaben auf "Danke erhalten" klicke wird auf den Beitrag verlinkt der dieses Danke erhalten hat. Auch dort wenn ich auf den Betreff klicke wird wieder verlinkt auf z.B. http://www.techno-com.de/Forum/post14149.html#p14149 , also auch nicht "SEO-Rewrite-mässig" !

Wie oben schon gesagt - ich kann dir da leider nicht weiter helfen.


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0

Beitragvon techno-com » 25. Feb 2012 09:18

Parallel habe ich gerade Punkt 4 ergänzt !!!! Du warst mal wieder "zu schnell" ! :verliebt

Habe deine Antwort noch nicht gelesen, muss jetzt erst mal zur Arbeit fahren ....


P.S. doch kurz "angelesen" ! Was "hältst" du von Punkt 1 ? Meinung ?

P.P.S. bitte empfehle mir noch kurz ein Board für die SEO-Fragen, am besten eines das deutsch geführt wird (damit meine ich die Sprache und nicht den Stil :razz )
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 744
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0

Beitragvon Mahony » 25. Feb 2012 10:43

Hallo
Zu 1. Es bleibt dir überlassen, ob du den Gästen das lesen erlaubst (oder eben nicht). Ich persönlich halte nichts davon, das lesen für Gäste zu verbieten. Es reicht ja, wenn man sich registrieren muss um Fragen stellen zu können (also schreibrechte für Gäste deaktivieren).

techno-com hat geschrieben:empfehle mir noch kurz ein Board für die SEO-Fragen

Hm...hier gibt es ein spezialisiertes Forum http://forum.modrewrite.de/


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0

Beitragvon techno-com » 25. Feb 2012 12:07

Kurzes: Mahony, die Info über neue Beiträge scheint akt. nicht zu funktionieren ! Habe für alle Antworten von dir keine Info erhalten obwohl ich "sofortige Benachrichtigung" aktiviert habe ! ===> vergess das ... war doch die Benachrichtigung nicht an ! Habe ich gerade nachgeholt ! Kopf noch im Bett... total verspult ! Zu viel "Rouge" (i.d.R. "Rotwein") noch im Kopf vom Skiausflug vorige Woche..

Kurzes Teil2: werde es dort mal eingestellen, habe vorher natürlich auch dort etwas mal gelesen (meine Freischaltung vom Account von dort kommt aber akt. nicht)---- soll ich denen mal was von einem "Rauschmass" erklären ? Soviel wie die dann verstehen würden verstehe ich von dem "Kauderwelsch" dort... wow, echt super kompliziert dieses Thema ! lach..

P.S. noch einen Tip zu 4. (das "nachgereichte) ?
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Unstimmigkeiten Thanks-Mod (1.3.3) -> SEO-Mod Advanced 0

Beitragvon techno-com » 7. Mär 2012 18:24

Mahony hat geschrieben:Zu3.
techno-com hat geschrieben:Da zerreisst es mir akt. die Struktur/den Aufbau eines Beitrags !

Ich kann mir das nächste Woche mal ansehen. Im Moment habe ich nicht die nötige Zeit dazu.

Servus mal wieder....

Hattest du mal Lust und Laune (es eilt absolut nicht !!!) dir das anzuschauen ? Sieht nicht wirklich prikelnd aus.

Dann hatte ich heute, "Facebook-geht-nicht-Tag" auch was ganz komisches.... Habe in jedem Beitrag oben unter der Betreff-Zeile den Like-Button von Facebook eingebaut, der ging ja dann auch nicht (wurde nur verzogen angezeigt).... dadurch wurden aber auch viele Funktionen vom Forum auf einmal gestört, z.B. das Resize ! Klingt komisch, war aber echt so. Hast du dafür eine "Erklärung" ?

Diverse Grafiken/Bilder werden auch jetzt noch groß angezeigt und poppen nicht auf (Highslide !), z.B. hier. Ich bin mir jetzt nicht 100% sicher (nur 75%), aber die waren mal resized und poppten auf als Highslide und nicht so wie jetzt auf einer neuen Seite. Das hattest du doch mal nachträglich für die "alten" Bilder synchronisiert über das STK, oder habe ich da was falsches im Hinterkopf ? Ginge das für die alten Bilder den überhaupt (wenn das nicht schon mal war) ?


P.S. in Angelegenheit SEO tut sich nicht viel in meiner parallelen Anfrage => http://forum.modrewrite.de/seo-url-prob ... t7983.html
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6


Zurück zu „Support für phpBB 3.0.x MODs“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast