Problem mit Thank Post Mod (hide MOD compatible )

Hier kommen die Support Anfragen für phpBB 3.0.x MODs hinein.
Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon techno-com » 3. Feb 2012 13:37

Mahony hat geschrieben:Die Sprachdateien (info_acp_thanks.php, info_ucp_thanks.php, thanks_mod.php ) müssen sich im Verzeichnis language/de/mods/ befinden. Wenn die Anzeige für "Kann sich für Beiträge Bedanken" dann nicht in den Gruppenspezifischen Forenrechten auftaucht, wurde der entsprechende Datenbank-Eintrag nicht vorgenommen.

Die "Sprachdateien" liegen dort unter "DE" ! Das nutze ich ja auch und daher war das sogar mit klar :verliebt "etwas", echt nur etwas, verstehe ich ja mittlerweile auch :idea:
Datenbankeintrag
Bild

Mahony hat geschrieben:Lösung: Den MOD mittels der install_thanks_mod.php deinstallieren und dann erneut installieren.

Danke.. habe es deinstalliert + neu installiert + alles "reseted" (incl. Cache clear)....

Immer noch kein "can thanks for post" in den Berechtigungen (Allgemeine Berechtigungen => Gruppenrechte") drin ............ nur bei "Forums-Rollen / Hier kannst du Rollen für Forum-Berechtigungen verwalten. Rollen sind zugewiesene Berechtigungen; wenn du eine Rolle änderst, ändern sich die Rechte aller Elemente, denen diese Rolle zugewiesen wurde." kann ich dieses "Diverses" finden und da ist es auch aktiviert.

Hier das von "Foren-Rollen"
Bild

und hier die Ausgabe bei der Installation (sehr lang, daher ganz am Ende mal reingepflügt)

Code: Alles auswählen

Lege neue Konfigurationsvariable an: remove_thanks
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_postlist_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_profilelist_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_counters_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_number
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_info_page
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_only_first_post
Erfolgreich

Füge neue Berechtigungsoption hinzu: f_thanks
Erfolgreich

Füge neue Berechtigungsoption hinzu: u_viewthanks
Erfolgreich

Setze Berechtigungen für die Standard-Funktionalität-Rolle.
Erfolgreich

Setze Berechtigungen für die REGISTERED-Gruppe.
Erfolgreich

Setze Berechtigungen für die Standard-Zugang-Rolle.
Erfolgreich

Eine neue Datenbanktabelle erstellen: phpbb_thanks
Erfolgreich

Eine neue Spalte user_allow_thanks_pm der Tabelle phpbb_users hinzufügen
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Entferne acp-Modul: ACP_THANKS
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_number_post
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS_SETTINGS
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS_REFRESH
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS_TRUNCATE
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_post_reput_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_topic_reput_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_forum_reput_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_reput_height
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_reput_level
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_number_digits
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_number_row_reput
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_reput_graphic
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_reput_image
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_reput_image_back
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_time_view
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_top_number
Erfolgreich

Füge acp-Modul hinzu: ACP_THANKS_REPUT_SETTINGS
Erfolgreich

Füge neue Berechtigungsoption hinzu: u_viewtoplist
Erfolgreich

Setze Berechtigungen für die REGISTERED-Gruppe.
Erfolgreich

Setze Berechtigungen für die Standard-Funktionalität-Rolle.
Erfolgreich

Eine neue Spalte topic_id der Tabelle phpbb_thanks hinzufügen
Erfolgreich

Eine neue Spalte forum_id der Tabelle phpbb_thanks hinzufügen
Erfolgreich

Eine neue Spalte thanks_time der Tabelle phpbb_thanks hinzufügen
Erfolgreich

Werte für die _thanks Tabelle aktualisieren
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Eine neue Spalte user_allow_thanks_email der Tabelle phpbb_users hinzufügen
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Füge neue Berechtigungsoption hinzu: m_thanks
Erfolgreich

Setze Berechtigungen für die Umfassender Moderator-Rolle.
Erfolgreich

Setze Berechtigungen für die Volle Funktionalität-Rolle.
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_forum_reput_view_column
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_topic_reput_view_column
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_notice_on
Erfolgreich

Aktualisiere Konfigurationsvariable: thanks_reput_image
Erfolgreich

Aktualisiere Konfigurationsvariable: thanks_reput_image_back
Erfolgreich

Aktualisiere Konfigurationsvariable: thanks_top_number
Erfolgreich

Setze Berechtigungen für die Voller Zugang-Rolle.
Erfolgreich

Aktualisiere die Grafiksammlung prosilver
Erfolgreich

Aktualisiere das Theme prosilver
Erfolgreich

Leere Cache des Forums
Erfolgreich

Lege neue Konfigurationsvariable an: thanks_mod_version
Erfolgreich
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 758
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 4 Mal

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Mahony » 3. Feb 2012 14:17

Hallo
Wenn du die deutschen Sprachdateien verwendest, sollte die Anzeige bei der Berechtigung auch in deutsch erscheinen. Insofern bezweifle ich, dass die(deutschen) Sprachdateien am richtigen Platz sind.

techno-com hat geschrieben:Immer noch kein "can thanks for post" in den Berechtigungen (Allgemeine Berechtigungen => Gruppenrechte")

Na das ist ja auch logisch. Es handelt sich ja um ein Forenrecht und nicht um ein Gruppenrecht. Du findest die Berechtigung unter Benutzer und Gruppen - Gruppenspezifische Forenrechte - Gruppe auswählen und weiter - Forum auswählen und weiter - auf Erweiterte Berechtigungen und hier unter Diverses --> Kann sich für Beiträge Bedanken

Du kannst eine entsprechende Rolle erstellen und diese neue Rolle den Foren zuweisen.
Siehe dazu auch Rechtevergabe im phpBB3


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon techno-com » 3. Feb 2012 15:19

Danke...diese "Forenrechte" waren mir noch nie so klar wie jetzt ! habe das jetzt alles mal fertig gemacht (Rechte zugewiesen das alle das Recht haben auf das "thanks" !) und auch die Sprachdatei mal überprüft... ich hatte zwar die in englischer Sprache die normal unter en rein muss, die war aber unter de drin ... habe das jetzt die deutsche Übersetzung drüber installiert und auch das geht !

ABER... der Danke-Button geht immer noch nicht !

Klicke ich ihne an passiert nichts außer das genau die Zeile nach oben an den Bildschirmrand gescrollt wird in der der Danke-Button ist..... sonst nichts weiteres !
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 758
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 4 Mal

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Mahony » 3. Feb 2012 15:43

Hallo
Überprüfe ob alle Dateien des MODs in die richtigen Verzeichnisse kopiert (hoch geladen) wurden.
Ansonsten tippe ich auf einen Einbaufehler. Ich würde da mal die viewtopic.php
überprüfen.


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon techno-com » 3. Feb 2012 16:18

VERDAMMT... ich bin jetzt das 3. mal alles durch !

Jede Änderung ist 3x geprüft, ich habe schon eckige Augen ..........

Die viewtopic.php habe ich jetzt auf Grund deines Beitrags zuvor sogar 10x durchgeschaut.... ich finde einfach KEINEN Einbau-Fehler ! Die Dateien habe ich jetzt auch noch einmal neu übertragen, sind auch alle online ! Dann auch noch einmal das MOD deinstalliert + neu installiert und auch wieder reseted + Cache gelöscht....

Es will nicht ................

Immer wenn ich den Button drücke "hüpft" nur genau die Zeile worin dieser "Danke-Button" ist nach ganz oben im Browser-Fenster ! Egal welche Button ich in einem Beitrag anklicke, immer wieder rutscht genau diese Zeile in welcher dieser Button ist nach oben .....
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 758
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 4 Mal

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Mahony » 3. Feb 2012 16:53

Hallo
Wie ich sehe, hast du einen SEO-MOD installiert. Ich denke mal, es liegt an diesem SEO-MOD.

Schau mal hier http://www.phpbb.com/customise/db/mod/t ... /faq/f_381


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
techno-com
Beiträge: 55
Registriert: 16. Aug 2010 12:28
Familienstand: Verheiratet
Wohnort: 74076 Heilbronn/ Germany
Kontaktdaten:

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon techno-com » 6. Feb 2012 16:13

Dann ist das ja wohl etwas das ich "übersehen" habe in den FAQs (obwohl ich die durchgeschaut habe, dort habe ich ja auch "german language" her !)...

Und was soll ich sagen .... DANKEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE für diesen Hinweis und den Link !

ES GEHT !!!!!

Ich danke dir vielmals Mahony, du hast mir schon wieder geholfen (hatte schon div. male bei solchen Anfragen Hilfe von dir ! Aber bisher immer in anderen Foren wo ich entsprechende Themen immer ergänzt hatte mit meinen Problemen).
https://www.satshop-heilbronn.de
https://www.satanlagenforum.de
Version 3.0.13-PL1
Board3 Portal 2.0.2
Tapatalk
phpBB SEO Class 0.7.0-/Mode:Advanced
Advanced BBcodes Box 3.0.11 (Highslide)
Wer war da 1.2.1
Thanks for Post 1.3.5
phpBB Galerie 1.1.6

Benutzeravatar
Loewenherz
Beiträge: 2
Registriert: 10. Aug 2012 17:09
Familienstand: Vergeben

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Loewenherz » 10. Aug 2012 17:18

Hi,
hab via Google hergefunden und das gleiche Problem. Beim Klick auf Danke passiert nix, außer dass man beim ersten Post eines Threads landet.
Bei mir ist seo-phpBB von Tobi aktiv, der sein Forum aber leider eingestellt hat. Insofern vermute ich, dass der verlinkte Tipp bei mir nix bringt.
Mahony, hast du eine Idee, was ich tun könnte?
Ergänzung: Eine Sache klappt beim seo phpBB Mod nicht: Wenn ich auf der Startseite des Forums auf den kleinen Button klicke, der mich zum neusten Posting in einem Thread führt, lande ich stattdessen immer beim ersten (also analog zum Problem mit dem Dankes-Mod - vielleicht besteht ja ein Zusammenhang).
Viele Grüße von einem Ex-Teammitglied :)

Falls es hilft: Es geht um dieses Forum: http://www.reiki-land.de/reiki-forum/

Benutzeravatar
Mahony
Site Admin
Site Admin
Beiträge: 758
Registriert: 3. Dez 2006 22:09
Hat sich bedankt: 1 Mal
Danksagung erhalten: 4 Mal

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Mahony » 10. Aug 2012 17:42

Hallo
Wenn du einen MOD installierst, der nicht mehr weiter entwickelt wird dann ist klar dass es irgendwann zu Problemen kommt. Ich empfehle dir den MOD von Tobi wieder auszubauen und statt dessen einen MOD zu wählen der auch weiter gepflegt wird.

Ansonsten bist du übrigens bei mir im Forum falsch, da du nicht meinen MOD installiert hast sondern den Thanks for posts MOD. Support für diesen MOD gibt es beim Entwickler der MOD denn der kennt seinen MOD schließlich am besten.
Loewenherz hat geschrieben:Wenn ich auf der Startseite des Forums auf den kleinen Button klicke, der mich zum neusten Posting in einem Thread führt, lande ich stattdessen immer beim ersten (also analog zum Problem mit dem Dankes-Mod - vielleicht besteht ja ein Zusammenhang).

Ja, da besteht ganz sicher ein Zusammenhang, nur kann ich ohne Einsicht in den Code nichts genaues dazu sagen (nur soviel - es liegt mit ziemlicher Sicherheit am SEO-MOD).

P.S. Tobis Seite ist ja noch online, evtl. findest du dort ja etwas zu deinem Problem http://www.phpbb-seo.de/
Eventuell hilft ja das hier https://www.phpbb-seo.de/forum/fragen-z ... -t552.html

Suche (in der includes/functions_display.php)

Code: Alles auswählen

    // Begin SEO phpBB
            $forum_rows[$parent_id]['last_forum'] = $row['forum_name'];
            $forum_rows[$parent_id]['topic_id'] = $row['topic_id'];
            // End SEO phpBB


Ersetze mit

Code: Alles auswählen

// Begin SEO phpBB
        $forum_rows[$parent_id]['last_forum'] = $row['forum_name'];
        $forum_rows[$parent_id]['topic_id'] = $row['topic_id'];
        $forum_rows[$parent_id]['topic_replies'] = $row['topic_replies'];
        // End SEO phpBB


Grüße: Mahony
Diejenigen, die lautstark darüber diskutieren, warum es nicht geht, mögen bitte jene nicht stören, die es gerade tun.
Klug ist, wer nur die Hälfte von dem glaubt, was er hört. Weise ist, wer erkennt, welche Hälfte richtig ist.

Bild

Benutzeravatar
Loewenherz
Beiträge: 2
Registriert: 10. Aug 2012 17:09
Familienstand: Vergeben

Re: Problem mit Thank Post Mod (hide MOD compatible )

Beitragvon Loewenherz » 10. Aug 2012 19:13

Danke für die Hilfe Mahony. Sorry, ist mir völlig entgangen, dass es auch beim Bedanken um einen anderen Mod ging, hab mich schon gewundert, dass du andere Buttons verwendest ;-)
Wobei ich tatsächlich und erfolgreich diese Sprachdateien eingesetzt habe: http://www.phpbb.com/customise/db/mod/t ... .3-t_97120 - jetzt bin ich verwirrt, hab heute wohl zu viele Codezeilen gesehen....

Der Tipp mit der ergänzenden Zeile bei Tobis Mod hat geholfen. Muss mal schauen, ob ich den wirklich zeitnah ausbaue, da sich dann wieder die URLs ändern.

In phpbb.com habe ich noch nicht angefragt beim Autor, da ich dort im Forum aktuell nicht reinkomme. Mein letzter Post dort ist schon Jahre her, keine Ahnung, ob die mich gelöscht haben oder was dort passiert ist. Würd ja gern mit altem Account weitermachen bevor ich einen neuen anlege.

cu
Frank


Zurück zu „Support für phpBB 3.0.x MODs“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast